// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n"#).unwrap();
let string = "\\nnew\"test\\naaaa\\\\\\n\"\\nta\\n`this is a \\nnewline that should be kept`\\n'this is a \\nnew test'\\n
Have a look at \"\\\\\\n\"";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}