$re = '/("[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'|`[^`\\\\]*(?:\\\\.[^`\\\\]*)*`)|\\\\n/';
$str = '\\nnew"test\\naaaa\\\\\\n"\\nta\\n`this is a \\nnewline that should be kept`\\n\'this is a \\nnew test\'\\n
Have a look at "\\\\\\n"';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;