package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n`)
var str = `\nnew"test\naaaa\\\n"\nta\n\`this is a \nnewline that should be kept\`\n'this is a \nnew test'\n
Have a look at "\\\n"`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}