const regex = /("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'|`[^`\\\\]*(?:\\\\.[^`\\\\]*)*`)|\\\\n', 'g')
const str = `\\nnew"test\\naaaa\\\\\\n"\\nta\\n\`this is a \\nnewline that should be kept\`\\n'this is a \\nnew test'\\n
Have a look at "\\\\\\n"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);