use strict;
my $str = '\\nnew"test\\naaaa\\\\\\n"\\nta\\n`this is a \\nnewline that should be kept`\\n\'this is a \\nnew test\'\\n
Have a look at "\\\\\\n"';
my $regex = qr/("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";