re = /("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n/
str = '\\nnew"test\\naaaa\\\\\\n"\\nta\\n`this is a \\nnewline that should be kept`\\n\'this is a \\nnew test\'\\n
Have a look at "\\\\\\n"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result