#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n"
Local $sString = "\nnew"test\naaaa\\\n"\nta\n`this is a \nnewline that should be kept`\n'this is a \nnew test'\n" & @CRLF & _
"" & @CRLF & _
"Have a look at "\\\n""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)