#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.+?)\["
Local $sString = "Word1 Word2 word3 [some words in brackets]" & @CRLF & _
"Word1 [some words in brackets]" & @CRLF & _
"word1, Word2 [some words in brackets]" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "%htmltag%\1%/htmltag%["
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)