package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+?)\[`)
var str = `Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
`
var substitution = "%htmltag%\1%/htmltag%["
fmt.Println(re.ReplaceAllString(str, substitution))
}