// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.+?)\[").unwrap();
let string = "Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
";
let substitution = "%htmltag%\\1%/htmltag%[";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}