import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?)\\[";
final String string = "Word1 Word2 word3 [some words in brackets]\n"
+ "Word1 [some words in brackets]\n"
+ "word1, Word2 [some words in brackets]\n\n";
final String subst = "%htmltag%\\1%/htmltag%[";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}