using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)\[";
string substitution = @"%htmltag%\1%/htmltag%[";
string input = @"Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}