import Foundation
let pattern = #"(.+?)\["#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%htmltag%\1%/htmltag%["#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)