const regex = /(.+?)\[/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)\\[', 'g')
const str = `Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
`;
const subst = `%htmltag%\1%/htmltag%[`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);