use strict;
my $str = 'Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
';
my $regex = qr/(.+?)\[/p;
my $subst = '%htmltag%\\1%/htmltag%[';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";