$re = '/(.+?)\[/';
$str = 'Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
';
$subst = "%htmltag%\1%/htmltag%[";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;