using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|;)(([^;]{1,10})([^;]*))";
string substitution = @"$3";
string input = @"firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}