package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(^|;)(([^;]{1,10})([^;]*))`)
var str = `firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}