// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(^|;)(([^;]{1,10})([^;]*))").unwrap();
let string = "firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate";
let substitution = "$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}