import re
regex = re.compile(r"(^|;)(([^;]{1,10})([^;]*))", flags=re.IGNORECASE | re.MULTILINE)
test_str = "firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate"
subst = "$3"
result = regex.sub(subst, test_str)
if result:
print(result)