use strict;
my $str = 'firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate';
my $regex = qr/(^|;)(([^;]{1,10})([^;]*))/imp;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";