using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search";
string input = @"<div class=""center"">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class=""center"">Showing 2343098 (search took 1.245 seconds)</div>
<div class=""center"">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}