package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search`)
var str = `<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class="center">Showing 2343098 (search took 1.245 seconds)</div>
<div class="center">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}