re = /Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search/
str = '<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class="center">Showing 2343098 (search took 1.245 seconds)</div>
<div class="center">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end