import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Showing\\s+(?:\\d+\\s+of\\s+)?([\\d,.]+)\\s+\\(search";
final String string = "<div class=\"center\">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>\n"
+ "<div class=\"center\">Showing 2343098 (search took 1.245 seconds)</div>\n"
+ "<div class=\"center\">\n\n"
+ " Showing 125 \n\n"
+ " of 2,343,098 \n\n\n\n\n"
+ "(search took 1.245 seconds)</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}