use strict;
my $str = '<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class="center">Showing 2343098 (search took 1.245 seconds)</div>
<div class="center">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>';
my $regex = qr/Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}