const regex = /Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Showing\\s+(?:\\d+\\s+of\\s+)?([\\d,.]+)\\s+\\(search', 'g')
const str = `<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class="center">Showing 2343098 (search took 1.245 seconds)</div>
<div class="center">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}