// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search").unwrap();
let string = "<div class=\"center\">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class=\"center\">Showing 2343098 (search took 1.245 seconds)</div>
<div class=\"center\">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}