$re = '/Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search/';
$str = '<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class="center">Showing 2343098 (search took 1.245 seconds)</div>
<div class="center">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);