# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*<\/secondary_references>/%/gu;t' <<< "<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>"