re = /<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*<\/secondary_references>/
str = '<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>'
subst = '%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result