const regex = new RegExp('<secondary_references>(\\[id=(\\d+)\\]([-, ]{0,2}))*</secondary_references>', 'gu')
const str = `<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>`;
const subst = `%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);