// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*</secondary_references>").unwrap();
let string = "<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>";
let substitution = "%";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}