import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<secondary_references>(\\[id=(\\d+)\\]([-, ]{0,2}))*</secondary_references>";
final String string = "<secondary_references>[id=1],[id=2]</secondary_references>\n"
+ "<secondary_references>[id=1]</secondary_references>\n"
+ "<secondary_references>[id=1]-[id=2]</secondary_references>\n"
+ "<secondary_references>[id=1][id=2]</secondary_references>";
final String subst = "%";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}