import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*</secondary_references>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)