$re = '/<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*</secondary_references>/u';
$str = '<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>';
$subst = "%";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;