using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*</secondary_references>";
string substitution = @"%";
string input = @"<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}