#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*</secondary_references>"
Local $sString = "<secondary_references>[id=1],[id=2]</secondary_references>" & @CRLF & _
"<secondary_references>[id=1]</secondary_references>" & @CRLF & _
"<secondary_references>[id=1]-[id=2]</secondary_references>" & @CRLF & _
"<secondary_references>[id=1][id=2]</secondary_references>"
Local $sSubst = "%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)