use strict;
my $str = '<secondary_references>[id=1],[id=2]</secondary_references>
<secondary_references>[id=1]</secondary_references>
<secondary_references>[id=1]-[id=2]</secondary_references>
<secondary_references>[id=1][id=2]</secondary_references>';
my $regex = qr/<secondary_references>(\[id=(\d+)\]([-, ]{0,2}))*</secondary_references>/up;
my $subst = '%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";