# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^lease.*(\n)*{$/\\$0/gm;t' <<< "lease 192.168.0.1
{
"