import re
regex = re.compile(r"^lease.*(\n)*{$", flags=re.MULTILINE)
test_str = ("lease 192.168.0.1\n"
"{\n")
subst = "\\\\$0"
result = regex.sub(subst, test_str)
if result:
print(result)