$re = '~^lease.*(\n)*{$~m';
$str = 'lease 192.168.0.1
{
';
$subst = "\\$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;