package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^lease.*(\n)*{$`)
var str = `lease 192.168.0.1
{
`
var substitution = "\\$0"
fmt.Println(re.ReplaceAllString(str, substitution))
}