using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+";
string substitution = @"1$11";
string input = @"matrix(1.5, 0, 0, 2, 160, 160, 100)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}