const regex = /[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d.]+((,[\\s*\\d.]+){2},\\s*)[\\d.]+', '')
const str = `matrix(1.5, 0, 0, 2, 160, 160, 100)`;
const subst = `1$11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);