use strict;
my $str = 'matrix(1.5, 0, 0, 2, 160, 160, 100)';
my $regex = qr/[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+/p;
my $subst = '1$11';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";