import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d.]+((,[\\s*\\d.]+){2},\\s*)[\\d.]+";
final String string = "matrix(1.5, 0, 0, 2, 160, 160, 100)";
final String subst = "1$11";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}