import re
regex = re.compile(r"[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+")
test_str = "matrix(1.5, 0, 0, 2, 160, 160, 100)"
subst = "1$11"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)