re = /[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+/
str = 'matrix(1.5, 0, 0, 2, 160, 160, 100)'
subst = '1$11'
result = str.sub(re, subst)
# Print the result of the substitution
puts result