#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([abAB])\.([abAB])"
Local $sString = "a.b" & @CRLF & _
"a.B" & @CRLF & _
"A.b" & @CRLF & _
"A.B" & @CRLF & _
"1.2"
Local $sSubst = "\1. \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)